public inbox for isar-users@googlegroups.com
 help / color / mirror / Atom feed
From: Henning Schild <henning.schild@siemens.com>
To: Alexander Smirnov <alex.bluesman.smirnov@gmail.com>
Cc: <isar-users@googlegroups.com>
Subject: Re: [PATCH 11/16] meta: classes: make do_build always the end of the task-chain
Date: Wed, 2 Aug 2017 14:05:32 +0200	[thread overview]
Message-ID: <20170802140532.6e45c0ef@md1em3qc> (raw)
In-Reply-To: <CAJmB2rBP5c0u=RavcLcf4RnBPiL7nVi-At8fRdBAGRu=-RH32w@mail.gmail.com>

Am Wed, 2 Aug 2017 12:54:46 +0300
schrieb Alexander Smirnov <alex.bluesman.smirnov@gmail.com>:

> 2017-08-01 13:17 GMT+03:00 Henning Schild
> <henning.schild@siemens.com>:
> 
> > build is bitbakes default target and queing tasks behind it is
> > asking for trouble
> >  
> 
> Could you please specify more details about this.

If you run "bitbake <component>" what actually happens is "bitbake
<component> -c build". So keeping all the tasks before a possibly empty
do_build makes sure that manual invokations of bitbake always run all
tasks. I am not sure whether [deptask] defaults to build as well.
I would see it like the "all" target of a Makefile.

But thinking about it the "cp *.dep ..." could be seen like "make
install" and could be allowed to happen after the default task.

It is a matter of taste i guess. How should we proceed? Put
do_install_package after do_build or keep it in front?

Henning

> 
> > Introduce do_compile where we "build" the debian packages.
> >
> > Signed-off-by: Henning Schild <henning.schild@siemens.com>
> > ---
> >  meta/classes/dpkg.bbclass  | 8 ++++----
> >  meta/classes/image.bbclass | 2 +-
> >  2 files changed, 5 insertions(+), 5 deletions(-)
> >
> > diff --git a/meta/classes/dpkg.bbclass b/meta/classes/dpkg.bbclass
> > index 4228b0d..71c7122 100644
> > --- a/meta/classes/dpkg.bbclass
> > +++ b/meta/classes/dpkg.bbclass
> > @@ -13,19 +13,19 @@ PP = "/home/builder/${PN}"
> >  WORKDIR = "${BUILDCHROOT_DIR}/${PP}"
> >  S ?= "${WORKDIR}"
> >
> > -do_build[stamp-extra-info] = "${DISTRO}"
> > -
> >  # Build package from sources using build script
> > -do_build() {
> > +do_compile() {
> >      sudo chroot ${BUILDCHROOT_DIR} /build.sh ${PP}/${SRC_DIR}
> >  }
> >
> >  
> Probably it makes sense to use more evident task name like
> do_dpkg-buildpackage or short version - do_buildpackage.
> 'dpkg-buildpackage' is exactly what is executed in this task, it's
> not only about compiling.

I wanted to choose names that can be reused in other contexts, classes
later and stay close to gentoo/OE. But i do not care much about names
and will apply your suggestion.

Henning

> 
> > +addtask compile after do_unpack before do_install
> > +do_compile[stamp-extra-info] = "${DISTRO}"
> >
> >  # Install package to dedicated deploy directory
> >  do_install() {
> >      install -m 755 ${WORKDIR}/*.deb ${DEPLOY_DIR_DEB}/
> >  }
> >
> > -addtask install after do_build
> > +addtask install after do_compile before do_build
> >  do_install[dirs] = "${DEPLOY_DIR_DEB}"
> >  do_install[stamp-extra-info] = "${MACHINE}"
> > diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
> > index 3e4877c..8db3352 100644
> > --- a/meta/classes/image.bbclass
> > +++ b/meta/classes/image.bbclass
> > @@ -27,4 +27,4 @@ do_populate() {
> >  }
> >
> >  addtask populate before do_build
> > -do_populate[deptask] = "do_install"
> > +do_populate[deptask] = "do_build"
> > --
> > 2.13.0
> >
> > --
> > You received this message because you are subscribed to the Google
> > Groups "isar-users" group.
> > To unsubscribe from this group and stop receiving emails from it,
> > send an email to isar-users+unsubscribe@googlegroups.com.
> > To post to this group, send email to isar-users@googlegroups.com.
> > To view this discussion on the web visit
> > https://groups.google.com/d/
> > msgid/isar-users/32e4ef6d06af30a76fdb645a4108f817301d3007.1501582237.git.
> > henning.schild%40siemens.com. For more options, visit
> > https://groups.google.com/d/optout. 


  reply	other threads:[~2017-08-02 12:03 UTC|newest]

Thread overview: 64+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-01 10:17 [PATCH 00/16] fixes and introducing dpdk-bin support Henning Schild
2017-08-01 10:17 ` [PATCH 01/16] meta: ext4-img: copy and keep attributes, always copy with sudo Henning Schild
2017-08-02  7:48   ` Alexander Smirnov
2017-08-02 11:18     ` Henning Schild
2017-10-19 18:04   ` Henning Schild
2017-10-19 19:41     ` Alexander Smirnov
2017-08-01 10:17 ` [PATCH 02/16] meta: classes: use base.bbclass from bitbake Henning Schild
     [not found]   ` <CAJmB2rBjBqHxPKTna-XUtgmW9i-ooQwbACyFgQTQahTqUAxHcg@mail.gmail.com>
2017-08-02  8:21     ` Alexander Smirnov
2017-08-01 10:17 ` [PATCH 03/16] meta: isar-base: remove unused function Henning Schild
     [not found]   ` <CAJmB2rBwssbfjgqL2wAsOFfGUK7DbBY31tF_QhR09Ot0rmRVjQ@mail.gmail.com>
2017-08-02  8:20     ` Alexander Smirnov
2017-08-01 10:17 ` [PATCH 04/16] remove redundant variable THISDIR Henning Schild
2017-08-02  8:25   ` Alexander Smirnov
2017-08-02 11:20     ` Henning Schild
2017-08-01 10:17 ` [PATCH 05/16] meta: conf: use bitbake.conf from bitbake and apply local changes Henning Schild
2017-08-02  8:34   ` Alexander Smirnov
2017-08-02 11:22     ` Henning Schild
2017-08-01 10:17 ` [PATCH 06/16] meta: conf: clean up local bitbake config Henning Schild
2017-08-02  8:35   ` Alexander Smirnov
2017-08-02 11:23     ` Henning Schild
2017-08-01 10:17 ` [PATCH 07/16] classes: use WORKDIR and get rid of BUILDROOT Henning Schild
2017-08-02  9:24   ` Alexander Smirnov
2017-08-02 11:30     ` Henning Schild
2017-08-03 11:24     ` Henning Schild
2017-08-01 10:17 ` [PATCH 08/16] classes: move fetch and unpack into isar-base Henning Schild
2017-08-02  9:47   ` Alexander Smirnov
2017-08-02 11:33     ` Henning Schild
2017-08-01 10:17 ` [PATCH 09/16] meta: dpdk use [dirs] directive instead of mkdir Henning Schild
2017-08-01 10:17 ` [PATCH 10/16] meta: dpkg: reorder and rename do_install to install in addtask Henning Schild
2017-08-01 10:17 ` [PATCH 11/16] meta: classes: make do_build always the end of the task-chain Henning Schild
2017-08-02  9:54   ` Alexander Smirnov
2017-08-02 12:05     ` Henning Schild [this message]
2017-08-01 10:17 ` [PATCH 12/16] meta: dpkg rename install to install_package Henning Schild
2017-08-02  9:59   ` Alexander Smirnov
2017-08-01 10:17 ` [PATCH 13/16] meta: classes: move install_package to isar-base Henning Schild
2017-08-01 11:48   ` Claudius Heine
2017-08-01 14:00   ` Claudius Heine
2017-08-01 15:01     ` Henning Schild
2017-08-01 10:17 ` [PATCH 14/16] meta: classes: rename dpkg to dpkg-src Henning Schild
2017-08-02 10:02   ` Alexander Smirnov
2017-08-03 15:37     ` Henning Schild
2017-08-03 15:45       ` Jan Kiszka
2017-08-01 10:17 ` [PATCH 15/16] meta: add dpkg-bin class Henning Schild
2017-08-01 14:25   ` Claudius Heine
2017-08-01 15:10     ` Claudius Heine
2017-08-02 10:11       ` Alexander Smirnov
2017-08-02 10:25         ` Henning Schild
2017-08-02 12:31         ` Henning Schild
2017-08-02 12:50           ` Jan Kiszka
2017-08-02 13:40       ` Henning Schild
2017-08-02 15:03         ` Claudius Heine
2017-08-03  7:57           ` Henning Schild
2017-08-03 10:39             ` Claudius Heine
2017-08-03 14:17               ` Henning Schild
2017-08-02 11:11   ` Claudius Heine
2017-08-02 11:17     ` Claudius Heine
2017-08-02 11:26       ` Claudius Heine
2017-08-01 10:17 ` [PATCH 16/16] recipes-app/hello-bin: add example on how to use dpkg-bin Henning Schild
2017-08-02  6:33   ` Jan Kiszka
2017-08-02  6:55     ` Claudius Heine
2017-08-03 18:48     ` Henning Schild
2017-08-01 10:23 ` [PATCH 00/16] fixes and introducing dpdk-bin support Henning Schild
2017-08-01 11:24 ` Claudius Heine
2017-08-11  9:15 ` Alexander Smirnov
2017-08-11 10:35   ` Henning Schild

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170802140532.6e45c0ef@md1em3qc \
    --to=henning.schild@siemens.com \
    --cc=alex.bluesman.smirnov@gmail.com \
    --cc=isar-users@googlegroups.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox