From: Henning Schild <henning.schild@siemens.com>
To: isar-users@googlegroups.com
Cc: Henning Schild <henning.schild@siemens.com>
Subject: [PATCHv2 2/9] base-apt: use the "basename" command instead of pattern substitution
Date: Wed, 23 Oct 2019 13:42:20 +0200 [thread overview]
Message-ID: <20191023114227.31308-3-henning.schild@siemens.com> (raw)
In-Reply-To: <20191023114227.31308-1-henning.schild@siemens.com>
From: Henning Schild <henning.schild@siemens.com>
Cosmetic and not functional. Let us not reinvet the wheel and possibly
make mistakes.
Signed-off-by: Henning Schild <henning.schild@siemens.com>
---
meta/classes/base-apt-helper.bbclass | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/classes/base-apt-helper.bbclass b/meta/classes/base-apt-helper.bbclass
index 81df45a..c2db3f7 100644
--- a/meta/classes/base-apt-helper.bbclass
+++ b/meta/classes/base-apt-helper.bbclass
@@ -26,7 +26,7 @@ populate_base_apt() {
# robust than querying reprepro by name.
# Check if this package is taken from Isar-apt, if so - ingore it.
- base_name=${package##*/}
+ base_name=$( basename "${package}")
isar_package=$(find ${REPO_ISAR_DIR}/${DISTRO} -name $base_name)
if [ -n "$isar_package" ]; then
# Check if MD5 sums are identical. This helps to avoid the case
--
2.23.0
next prev parent reply other threads:[~2019-10-23 11:42 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-23 11:42 [PATCHv2 0/9] a few cleanups a bug and a feature Henning Schild
2019-10-23 11:42 ` [PATCHv2 1/9] rootfs: fix incorrect feature name in comment Henning Schild
2019-10-23 11:42 ` Henning Schild [this message]
2019-10-23 20:36 ` [PATCHv2 2/9] base-apt: use the "basename" command instead of pattern substitution Baurzhan Ismagulov
2019-10-24 9:16 ` Henning Schild
2019-10-24 12:01 ` Baurzhan Ismagulov
2019-10-24 9:34 ` chombourger
2019-10-24 12:01 ` Baurzhan Ismagulov
2019-10-23 11:42 ` [PATCHv2 3/9] base_apt_helper: change variable names to increase readability Henning Schild
2019-10-23 11:42 ` [PATCHv2 4/9] rootfs: rename ROOTFS_INSTALL_COMMAND lock to "isar-apt-lock" Henning Schild
2019-10-23 11:42 ` [PATCHv2 5/9] dpkg-base: remove pointless ";" s at end of line Henning Schild
2019-10-23 11:42 ` [PATCHv2 6/9] dpkg-base: fix indentation from tabs to spaces Henning Schild
2019-10-23 11:42 ` [PATCHv2 7/9] base: implement BB_NO_NETWORK for apt-get Henning Schild
2019-10-31 8:42 ` Henning Schild
2019-10-23 11:42 ` [PATCHv2 8/9] meta: do not equip rootfss with resolv.conf when BB_NO_NETWORK Henning Schild
2019-10-23 11:42 ` [PATCHv2 9/9] bootstrap: fix debootstrap gpg issue when base-apt is not signed Henning Schild
2019-10-23 11:43 ` [PATCHv2 0/9] a few cleanups a bug and a feature Henning Schild
2019-11-07 12:16 ` Jan Kiszka
2019-11-07 14:36 ` Henning Schild
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191023114227.31308-3-henning.schild@siemens.com \
--to=henning.schild@siemens.com \
--cc=isar-users@googlegroups.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox