2017-08-01 13:17 GMT+03:00 Henning Schild : > install will be used by later patches to actually populate debian > packages > > Signed-off-by: Henning Schild > --- > meta/classes/dpkg.bbclass | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/meta/classes/dpkg.bbclass b/meta/classes/dpkg.bbclass > index 71c7122..2a1b85c 100644 > --- a/meta/classes/dpkg.bbclass > +++ b/meta/classes/dpkg.bbclass > @@ -18,14 +18,14 @@ do_compile() { > sudo chroot ${BUILDCHROOT_DIR} /build.sh ${PP}/${SRC_DIR} > } > > -addtask compile after do_unpack before do_install > +addtask compile after do_unpack before do_install_package > do_compile[stamp-extra-info] = "${DISTRO}" > > # Install package to dedicated deploy directory > -do_install() { > +do_install_package() { > install -m 755 ${WORKDIR}/*.deb ${DEPLOY_DIR_DEB}/ > } > Keeping in mind possible integartion to OE/Yocto, probably rename task to do_install_deb_package? Just to avoid possible user confusion with OE internals. In general I like the idea to rename tasks in deb building chain to some unique names, to avoid mess with "classical" OE tasks. > > -addtask install after do_compile before do_build > -do_install[dirs] = "${DEPLOY_DIR_DEB}" > -do_install[stamp-extra-info] = "${MACHINE}" > +addtask install_package after do_compile before do_build > +do_install_package[dirs] = "${DEPLOY_DIR_DEB}" > +do_install_package[stamp-extra-info] = "${MACHINE}" > -- > 2.13.0 > > -- > You received this message because you are subscribed to the Google Groups > "isar-users" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to isar-users+unsubscribe@googlegroups.com. > To post to this group, send email to isar-users@googlegroups.com. > To view this discussion on the web visit https://groups.google.com/d/ > msgid/isar-users/448d9587745e4ce887e8f0768ddb3bbce5526751.1501582237.git. > henning.schild%40siemens.com. > For more options, visit https://groups.google.com/d/optout. >