* [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb'
@ 2017-09-15 11:31 Henning Schild
2017-09-15 11:31 ` [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install' Henning Schild
2017-09-19 15:15 ` [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Alexander Smirnov
0 siblings, 2 replies; 3+ messages in thread
From: Henning Schild @ 2017-09-15 11:31 UTC (permalink / raw)
To: isar-users; +Cc: Alexander Smirnov, Henning Schild
Issue:
The task name 'install' is a well known name from OE, gentoo, and other
similar build-systems. But in Isar it is used in a completely different
context, that might confuse Isar users. And we can not use the name for
what people would expect, as long as it is taken.
Change:
Rename the task.
Impact:
This patch does not change the behaviour of Isar. It just addresses the
issue.
Signed-off-by: Henning Schild <henning.schild@siemens.com>
---
doc/technical_overview.md | 2 +-
meta/classes/dpkg-base.bbclass | 8 ++++----
meta/classes/image.bbclass | 2 +-
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/doc/technical_overview.md b/doc/technical_overview.md
index f8ed9ee..c73cf08 100644
--- a/doc/technical_overview.md
+++ b/doc/technical_overview.md
@@ -190,7 +190,7 @@ Both consist of the following steps:
without compiling anything
-5. Task `do_install`: install successfully built packages
+5. Task `do_deploy_deb`: install successfully built packages
`${WORKDIR}/*.deb` to deploy directory `${DEPLOY_DIR_DEB}`
## 3.5 Populate Target Filesystem
diff --git a/meta/classes/dpkg-base.bbclass b/meta/classes/dpkg-base.bbclass
index 2402858..9ded3ae 100644
--- a/meta/classes/dpkg-base.bbclass
+++ b/meta/classes/dpkg-base.bbclass
@@ -27,10 +27,10 @@ do_build() {
}
# Install package to dedicated deploy directory
-do_install() {
+do_deploy_deb() {
install -m 644 ${WORKDIR}/*.deb ${DEPLOY_DIR_DEB}/
}
-addtask install after do_build
-do_install[dirs] = "${DEPLOY_DIR_DEB}"
-do_install[stamp-extra-info] = "${MACHINE}"
+addtask deploy_deb after do_build
+do_deploy_deb[dirs] = "${DEPLOY_DIR_DEB}"
+do_deploy_deb[stamp-extra-info] = "${MACHINE}"
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 590725c..5bf9524 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -28,4 +28,4 @@ do_populate() {
}
addtask populate before do_build
-do_populate[deptask] = "do_install"
+do_populate[deptask] = "do_deploy_deb"
--
2.13.5
^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install'
2017-09-15 11:31 [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Henning Schild
@ 2017-09-15 11:31 ` Henning Schild
2017-09-19 15:15 ` [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Alexander Smirnov
1 sibling, 0 replies; 3+ messages in thread
From: Henning Schild @ 2017-09-15 11:31 UTC (permalink / raw)
To: isar-users; +Cc: Alexander Smirnov, Henning Schild
Issue:
dpkg-raw uses an unfamiliar name for the step where files make it into
${D}, people coming from OE or gentoo could be confused
Change:
Rename the task from to 'install' which in this case fits the
expectations of people coming from other/similar build systems.
Impact:
Everyone that already based recipes on dpdk-raw.bbclass will have to
change the name in these recipes as well.
Signed-off-by: Henning Schild <henning.schild@siemens.com>
---
doc/technical_overview.md | 2 +-
meta-isar/recipes-app/example-raw/example-raw_0.1.bb | 2 +-
meta/classes/dpkg-raw.bbclass | 11 +++++------
3 files changed, 7 insertions(+), 8 deletions(-)
diff --git a/doc/technical_overview.md b/doc/technical_overview.md
index c73cf08..3b150b1 100644
--- a/doc/technical_overview.md
+++ b/doc/technical_overview.md
@@ -170,7 +170,7 @@ Both consist of the following steps:
2. Task `do_unpack`: unpack those files to `${WORKDIR}`
-3. Task `do_populate_package` _only_ for `dpkg-raw`: copy all you want in your
+3. Task `do_install` _only_ for `dpkg-raw`: copy all you want in your
debian package to `${D}`, install hooks in `${D}/DEBIAN`
4. Task `do_build`: mount folder with unpacked files to buildchroot, execute
diff --git a/meta-isar/recipes-app/example-raw/example-raw_0.1.bb b/meta-isar/recipes-app/example-raw/example-raw_0.1.bb
index 8cd2626..08c7277 100644
--- a/meta-isar/recipes-app/example-raw/example-raw_0.1.bb
+++ b/meta-isar/recipes-app/example-raw/example-raw_0.1.bb
@@ -12,7 +12,7 @@ SRC_URI = "file://README \
inherit dpkg-raw
-do_populate_package() {
+do_install() {
bbnote "Creating ${PN} binary"
echo "#!/bin/sh" > ${WORKDIR}/${PN}
echo "echo Hello ISAR! ${PN}_${PV}" >> ${WORKDIR}/${PN}
diff --git a/meta/classes/dpkg-raw.bbclass b/meta/classes/dpkg-raw.bbclass
index 6c6a89c..af62be4 100644
--- a/meta/classes/dpkg-raw.bbclass
+++ b/meta/classes/dpkg-raw.bbclass
@@ -9,16 +9,15 @@ MAINTAINER ?= "FIXME Unknown maintainer"
D = "${WORKDIR}/image/"
# Populate folder that will be picked up as package
-# TODO this should be called 'do_install'
-do_populate_package() {
+do_install() {
bbnote "Put your files for this package in ${D}"
}
-do_populate_package[stamp-extra-info] = "${DISTRO}-${DISTRO_ARCH}"
-addtask populate_package after do_unpack before do_deb_package_prepare
+do_install[stamp-extra-info] = "${DISTRO}-${DISTRO_ARCH}"
+addtask install after do_unpack before do_deb_package_prepare
# so we can put hooks etc. in there already
-do_populate_package[dirs] = "${D}/DEBIAN"
+do_install[dirs] = "${D}/DEBIAN"
do_deb_package_prepare() {
cat<<-__EOF__ > ${D}/DEBIAN/control
@@ -41,7 +40,7 @@ do_deb_package_prepare() {
}
do_deb_package_prepare[stamp-extra-info] = "${DISTRO}-${DISTRO_ARCH}"
-addtask deb_package_prepare after do_populate_package before do_deb_package_conffiles
+addtask deb_package_prepare after do_install before do_deb_package_conffiles
do_deb_package_conffiles() {
CONFFILES=${D}/DEBIAN/conffiles
--
2.13.5
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb'
2017-09-15 11:31 [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Henning Schild
2017-09-15 11:31 ` [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install' Henning Schild
@ 2017-09-19 15:15 ` Alexander Smirnov
1 sibling, 0 replies; 3+ messages in thread
From: Alexander Smirnov @ 2017-09-19 15:15 UTC (permalink / raw)
To: Henning Schild, isar-users
Applied to next, thanks.
On 09/15/2017 02:31 PM, Henning Schild wrote:
> Issue:
> The task name 'install' is a well known name from OE, gentoo, and other
> similar build-systems. But in Isar it is used in a completely different
> context, that might confuse Isar users. And we can not use the name for
> what people would expect, as long as it is taken.
>
> Change:
> Rename the task.
>
> Impact:
> This patch does not change the behaviour of Isar. It just addresses the
> issue.
>
> Signed-off-by: Henning Schild <henning.schild@siemens.com>
> ---
> doc/technical_overview.md | 2 +-
> meta/classes/dpkg-base.bbclass | 8 ++++----
> meta/classes/image.bbclass | 2 +-
> 3 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/doc/technical_overview.md b/doc/technical_overview.md
> index f8ed9ee..c73cf08 100644
> --- a/doc/technical_overview.md
> +++ b/doc/technical_overview.md
> @@ -190,7 +190,7 @@ Both consist of the following steps:
> without compiling anything
>
>
> -5. Task `do_install`: install successfully built packages
> +5. Task `do_deploy_deb`: install successfully built packages
> `${WORKDIR}/*.deb` to deploy directory `${DEPLOY_DIR_DEB}`
>
> ## 3.5 Populate Target Filesystem
> diff --git a/meta/classes/dpkg-base.bbclass b/meta/classes/dpkg-base.bbclass
> index 2402858..9ded3ae 100644
> --- a/meta/classes/dpkg-base.bbclass
> +++ b/meta/classes/dpkg-base.bbclass
> @@ -27,10 +27,10 @@ do_build() {
> }
>
> # Install package to dedicated deploy directory
> -do_install() {
> +do_deploy_deb() {
> install -m 644 ${WORKDIR}/*.deb ${DEPLOY_DIR_DEB}/
> }
>
> -addtask install after do_build
> -do_install[dirs] = "${DEPLOY_DIR_DEB}"
> -do_install[stamp-extra-info] = "${MACHINE}"
> +addtask deploy_deb after do_build
> +do_deploy_deb[dirs] = "${DEPLOY_DIR_DEB}"
> +do_deploy_deb[stamp-extra-info] = "${MACHINE}"
> diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
> index 590725c..5bf9524 100644
> --- a/meta/classes/image.bbclass
> +++ b/meta/classes/image.bbclass
> @@ -28,4 +28,4 @@ do_populate() {
> }
>
> addtask populate before do_build
> -do_populate[deptask] = "do_install"
> +do_populate[deptask] = "do_deploy_deb"
>
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2017-09-19 15:15 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-09-15 11:31 [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Henning Schild
2017-09-15 11:31 ` [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install' Henning Schild
2017-09-19 15:15 ` [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Alexander Smirnov
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox