public inbox for isar-users@googlegroups.com
 help / color / mirror / Atom feed
* [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb'
@ 2017-09-15 11:31 Henning Schild
  2017-09-15 11:31 ` [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install' Henning Schild
  2017-09-19 15:15 ` [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Alexander Smirnov
  0 siblings, 2 replies; 3+ messages in thread
From: Henning Schild @ 2017-09-15 11:31 UTC (permalink / raw)
  To: isar-users; +Cc: Alexander Smirnov, Henning Schild

Issue:
The task name 'install' is a well known name from OE, gentoo, and other
similar build-systems. But in Isar it is used in a completely different
context, that might confuse Isar users. And we can not use the name for
what people would expect, as long as it is taken.

Change:
Rename the task.

Impact:
This patch does not change the behaviour of Isar. It just addresses the
issue.

Signed-off-by: Henning Schild <henning.schild@siemens.com>
---
 doc/technical_overview.md      | 2 +-
 meta/classes/dpkg-base.bbclass | 8 ++++----
 meta/classes/image.bbclass     | 2 +-
 3 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/doc/technical_overview.md b/doc/technical_overview.md
index f8ed9ee..c73cf08 100644
--- a/doc/technical_overview.md
+++ b/doc/technical_overview.md
@@ -190,7 +190,7 @@ Both consist of the following steps:
 	without compiling anything
 
 
-5. Task `do_install`: install successfully built packages
+5. Task `do_deploy_deb`: install successfully built packages
    `${WORKDIR}/*.deb` to deploy directory `${DEPLOY_DIR_DEB}`
 
 ## 3.5 Populate Target Filesystem
diff --git a/meta/classes/dpkg-base.bbclass b/meta/classes/dpkg-base.bbclass
index 2402858..9ded3ae 100644
--- a/meta/classes/dpkg-base.bbclass
+++ b/meta/classes/dpkg-base.bbclass
@@ -27,10 +27,10 @@ do_build() {
 }
 
 # Install package to dedicated deploy directory
-do_install() {
+do_deploy_deb() {
     install -m 644 ${WORKDIR}/*.deb ${DEPLOY_DIR_DEB}/
 }
 
-addtask install after do_build
-do_install[dirs] = "${DEPLOY_DIR_DEB}"
-do_install[stamp-extra-info] = "${MACHINE}"
+addtask deploy_deb after do_build
+do_deploy_deb[dirs] = "${DEPLOY_DIR_DEB}"
+do_deploy_deb[stamp-extra-info] = "${MACHINE}"
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 590725c..5bf9524 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -28,4 +28,4 @@ do_populate() {
 }
 
 addtask populate before do_build
-do_populate[deptask] = "do_install"
+do_populate[deptask] = "do_deploy_deb"
-- 
2.13.5


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2017-09-19 15:15 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-09-15 11:31 [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Henning Schild
2017-09-15 11:31 ` [PATCH 2/2] meta: dpkg-raw: rename 'populate_package' to 'install' Henning Schild
2017-09-19 15:15 ` [PATCH 1/2] meta: dpkg-base: rename 'install' to 'deploy_deb' Alexander Smirnov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox