From: Henning Schild <henning.schild@siemens.com>
To: isar-users@googlegroups.com
Cc: Alexander Smirnov <alex.bluesman.smirnov@gmail.com>,
Henning Schild <henning.schild@siemens.com>
Subject: [PATCH 11-16 of 16 v2 0/6] and now for the second half
Date: Thu, 3 Aug 2017 21:15:18 +0200 [thread overview]
Message-ID: <cover.1501787333.git.henning.schild@siemens.com> (raw)
For a possible integration in OE you should use the same names. If your
base class inherits the OE base class you already have implementations.
Than your base class does not need to define the tasks and their order
anymore and you overwrite the tasks you do not need.
If we do not go on top of OE we should still use the same names for the
same tasks.
That is why i am still causing name-clashes here.
11v1 dropped
- do_compile would have been one matching OE name, but the match is
not perfect
12v1 -> 1v2
- use OE name
2v2
- is a completely new one, but seems obvious
13v1 -> 3v2
- create a new class isar-base-dpkg so images still have the fetcher
and unpacker
14v1 -> 4v2
- unchanged
15v1 -> 5v2
- update commit comment to explain why and what that is
- rename DEBIAN_MAINTAINER to MAINTAINER
- /find/find -type f/
- /> $CONFFILES/>> $CONFFILES/
- /sed ..||/sed .. |/|/ in the conffiles the leading / was missing
- put conffiles magic into its own task to allow easy
customization/disabling
- add a basic header, not sure how license headers should look like
16v1 -> 6v2
- use fetcher for FILES
- have an example conffile
- add a harmless depends example
- small changes to the example postinst
- introduce hack to handle BUILDROOT weirdness, needs to be discussed
further
Henning Schild (6):
meta: dpkg rename install to package_write_deb
package_write_deb: change access rights on .debs
meta: classes: move package_write_deb to new class isar-base-dpkg
meta: classes: rename dpkg to dpkg-src
meta: add dpkg-bin class
recipes-app/hello-bin: add example on how to use dpkg-bin
meta-isar/recipes-app/hello-bin/files/README | 1 +
meta-isar/recipes-app/hello-bin/files/postinst | 16 +++++++
meta-isar/recipes-app/hello-bin/hello-bin_0.1.bb | 38 ++++++++++++++++
meta-isar/recipes-app/hello/hello.bb | 2 +-
meta/classes/dpkg-bin.bbclass | 56 ++++++++++++++++++++++++
meta/classes/dpkg-src.bbclass | 15 +++++++
meta/classes/dpkg.bbclass | 34 --------------
meta/classes/image.bbclass | 2 +-
meta/classes/isar-base-dpkg.bbclass | 40 +++++++++++++++++
9 files changed, 168 insertions(+), 36 deletions(-)
create mode 100644 meta-isar/recipes-app/hello-bin/files/README
create mode 100644 meta-isar/recipes-app/hello-bin/files/postinst
create mode 100644 meta-isar/recipes-app/hello-bin/hello-bin_0.1.bb
create mode 100644 meta/classes/dpkg-bin.bbclass
create mode 100644 meta/classes/dpkg-src.bbclass
delete mode 100644 meta/classes/dpkg.bbclass
create mode 100644 meta/classes/isar-base-dpkg.bbclass
--
2.13.0
next reply other threads:[~2017-08-03 19:13 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-08-03 19:15 Henning Schild [this message]
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 1/6] meta: dpkg rename install to package_write_deb Henning Schild
2017-08-08 13:06 ` Alexander Smirnov
2017-08-08 14:49 ` Henning Schild
2017-08-08 15:06 ` Alexander Smirnov
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 2/6] package_write_deb: change access rights on .debs Henning Schild
2017-08-08 13:16 ` Alexander Smirnov
2017-08-21 23:14 ` Baurzhan Ismagulov
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 3/6] meta: classes: move package_write_deb to new class isar-base-dpkg Henning Schild
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 4/6] meta: classes: rename dpkg to dpkg-src Henning Schild
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 5/6] meta: add dpkg-bin class Henning Schild
2017-08-03 19:15 ` [PATCH 11-16 of 16 v2 6/6] recipes-app/hello-bin: add example on how to use dpkg-bin Henning Schild
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1501787333.git.henning.schild@siemens.com \
--to=henning.schild@siemens.com \
--cc=alex.bluesman.smirnov@gmail.com \
--cc=isar-users@googlegroups.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox