From: "'MOESSBAUER, Felix' via isar-users" <isar-users@googlegroups.com>
To: "Kiszka, Jan" <jan.kiszka@siemens.com>,
"isar-users@googlegroups.com" <isar-users@googlegroups.com>
Subject: Re: [PATCH 5/5] kernel: use architecture specific names for kernels
Date: Thu, 13 Aug 2026 18:46:51 +0000 [thread overview]
Message-ID: <d5f813bdf0d016b85db13977de3380b02f9e5498.camel@siemens.com> (raw)
In-Reply-To: <5cb44a40-b33e-4b1e-8ec3-f93cf278f107@siemens.com>
On Thu, 2026-08-13 at 19:47 +0200, Jan Kiszka wrote:
> On 13.08.26 18:45, Felix Moessbauer wrote:
> > The kernel source packages are architecture specific. By that, we also
> > have to encode the architecture in the KERNEL_NAME, if that is not
> > already implicitly the case (e.g. when building a kernel for a specific
> > machine).
> >
> > For the kernel recipes which are generic (like mainline and cip), we
> > simply extend the PN with -${DISTRO_ARCH}, so bitbake can find the
> > dependency and instanciate an architecture specific variant.
> >
> > By that, we also need to adapt the default in test_per_kernel, which
> > explicitly builds the module for the kernel that corresponds to the
> > multiconfig target.
> >
> > Signed-off-by: Felix Moessbauer <felix.moessbauer@siemens.com>
> > ---
> > RECIPE-API-CHANGELOG.md | 18 ++++++++++++++++++
> > meta-isar/conf/machine/beagleplay.conf | 2 +-
> > meta-isar/conf/machine/de0-nano-soc.conf | 2 +-
> > meta-isar/conf/machine/hikey.conf | 2 +-
> > meta-isar/conf/machine/qemuamd64-cip.conf | 2 +-
> > meta-isar/conf/machine/sifive-fu540.conf | 2 +-
> > meta-isar/conf/machine/stm32mp15x.conf | 2 +-
> > .../linux/linux-cip_4.4.166-cip29.bb | 2 ++
> > .../linux/linux-mainline_6.12.85.bb | 2 ++
> > testsuite/citest.py | 2 +-
> > 10 files changed, 29 insertions(+), 7 deletions(-)
> >
> > diff --git a/RECIPE-API-CHANGELOG.md b/RECIPE-API-CHANGELOG.md
> > index 2db05169..c13a3b3f 100644
> > --- a/RECIPE-API-CHANGELOG.md
> > +++ b/RECIPE-API-CHANGELOG.md
> > @@ -1175,6 +1175,24 @@ DPKG_ARCH ?= "${DISTRO_ARCH}"
> >
> > Firmware packages are an exception because they are built for only one architecture.
> >
> > +### Kernel source packages are architecture specific
> > +
> > +Kernel source packages have always contained architecture-specific content, but
>
> See my comment on the cover letter: architecture or even
> machine-specific content.
This does not invalidate this statement. It just means there could be
even more differences. Anyways, just a cover letter ;)
>
> > +this was not previously enforced. As a result, builds for multiple architectures
> > +could publish different source packages with the same name and version.
> > +
> > +Generic kernel recipes can append `${DISTRO_ARCH}` to `PN`, to provide the
> > +kernel for all architectures.
> > +
> > +```
> > +PN .= "-${DISTRO_ARCH}"
> > +```
> > +
> > +For a kernel built for only one target, the name may remain unchanged. When
> > +building multiple instances of a kernel selected by the same `KERNEL_NAME`, use
> > +`${DISTRO_ARCH}` in the name for architecture-specific kernels, or `${MACHINE}`
> > +for machine-specific kernels.
> > +
>
> This is not written like a recipe API change. This way, it looks like
> something that belongs into the user manual, kernel section, as it
> provides guidance on how to model that special case. You need to
> explain, when this is now required while it was not before.
>
> But I would rather suggest modelling that more transparently, via
> PROVIDES: The KERNEL_NAME should remain "mainline", e.g., and the
> recipes should PROVIDE that generic name while actually building
> "mainline-$DISTRO_ARCH".
And this is exactly what "option 2" from [1] proposes, which I tried
and which does not work for two reasons:
1. on bitbake side, the provides and depends need to be fiddled through
the multiarch classes (-native), which I did not manage to implement.
For the kernel it worked, but not for the module recipes. It also gets
super messy on multiconfig builds with two different kernels (e.g. a
hardened one for the image and a "open" one for the installer).
2. We need provides on the debian package names as well, but resolving
multiple provides in the dependency install stages (sbuild and rootfs
install) is tricky, as we already know from other tries in this
direction.
Felix
> Jan
>
> --
> Siemens AG, Foundational Technologies
> Linux Expert Center
--
You received this message because you are subscribed to the Google Groups "isar-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to isar-users+unsubscribe@googlegroups.com.
To view this discussion visit https://groups.google.com/d/msgid/isar-users/d5f813bdf0d016b85db13977de3380b02f9e5498.camel%40siemens.com.
next prev parent reply other threads:[~2026-08-13 18:47 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-13 16:44 [PATCH 0/5] Fix single-name single-content rule for kernel packages 'Felix Moessbauer' via isar-users
2026-08-13 16:44 ` [PATCH 1/5] testsuite: make test_libc_dev_deploy KERNEL_NAME agnostic 'Felix Moessbauer' via isar-users
2026-08-13 16:44 ` [PATCH 2/5] kernel: bind x86_64_defconfig to amd64 architecture instead of machine 'Felix Moessbauer' via isar-users
2026-08-13 16:44 ` [PATCH 3/5] kernel: make source package architecture specific 'Felix Moessbauer' via isar-users
2026-08-13 16:44 ` [PATCH 4/5] kernel: move common parts of linux-mainline to inc 'Felix Moessbauer' via isar-users
2026-08-13 16:45 ` [PATCH 5/5] kernel: use architecture specific names for kernels 'Felix Moessbauer' via isar-users
2026-08-13 17:47 ` 'Jan Kiszka' via isar-users
2026-08-13 18:46 ` 'MOESSBAUER, Felix' via isar-users [this message]
2026-08-13 19:08 ` 'Jan Kiszka' via isar-users
2026-08-14 7:01 ` 'MOESSBAUER, Felix' via isar-users
2026-08-14 10:51 ` 'Jan Kiszka' via isar-users
2026-08-13 17:45 ` [PATCH 0/5] Fix single-name single-content rule for kernel packages 'Jan Kiszka' via isar-users
2026-08-13 17:50 ` 'Jan Kiszka' via isar-users
2026-08-13 18:06 ` 'Jan Kiszka' via isar-users
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d5f813bdf0d016b85db13977de3380b02f9e5498.camel@siemens.com \
--to=isar-users@googlegroups.com \
--cc=felix.moessbauer@siemens.com \
--cc=jan.kiszka@siemens.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox